What to do when the version of the connected device is not supported in Smart Switch?

Last Update Date : Dec 18. 2017

Make sure that the device model is supported by Smart Switch.

1 Galaxy S3, Note 2, Note 8 (Android 4.1.2 or later)
2 Galaxy S4 or later

Need more help? Contact Us.

Online

Live Chat

Monday to Friday (Excluding Public Holidays)
9:00am - 7:00pm

Email

We'll respond within 24 hours of your request.

Email to CEO

Contact the dedicated CEO's Office.

Call

1800-4252997For Mobile Device and Samsung Apps Enquiries

+65 69161260From Oversea

1800-7267864For other Products Enquiries

+65 69161261From Oversea

Monday to Sunday (Including Public Holidays)
8:00am - 8:00pm

* For any printer related enquiries, please visit HP website .

Face-to-face support

Samsung Service Centres

Find out more about how you can get face-to-face help.

Contact Us