Is my mobile device compatible with Galaxy Fitⓔ?

Last Update date : Oct 13. 2020

Galaxy Fitⓔ is compatible with Samsung mobile devices using Android OS 5.0 (API 21) or above with more than 1.5GB RAM and

iPhone 5 and above based on iOS 9.0 or above.

 

Compatible model list and available features may vary by brand, region, operator, and device model.

   

To connect your Galaxy Fitⓔ to a mobile device, install the Galaxy Wearable app on the mobile device.

   
Depending on your mobile device, you can download the Galaxy Wearable app from the following places:

    • Samsung Android devices: Galaxy Apps, Play Store

    • Other Android devices: Play Store

   
You cannot install the Galaxy Wearable app on a mobile device that does not support Galaxy Fitⓔ syncing.

   
Ensure that your mobile device is compatible with a Galaxy Fitⓔ.

Thank you for your feedback!